kali2020.3安装GVM-20(OpenVAS)

前言

很长时间没有使用OpenVAS了,上次使用的是OpenVAS-9。使用apt-get install openvas在kali20.3上安装OpenVAS,但是显示报错,发现从版本10开始,OpenVAS已重命名为GVM(Greenbone漏洞管理),最新版本为GVM-20。

1.环境准备

Kali linux老三个步骤,以确保将软件库更新为最新版本。

#sudo apt-get update //更新软件库

#sudo apt-get upgrade //升级软件

#sudo apt-get dist-upgrade //升级系统

#sudo apt-get clean //系统清理

初始化

sudo gvm-setup

经过漫长的等待

错误处理

错误:

The default postgresql version is not 13 required by libgvmd

解决: 使用pg_upgradecluster更新postgres集群 ,禁用当前默认的12版本,启用13版本

# sudo apt install postgresql-13

# sudo systemctl stop [email protected]

# sudo systemctl daemon-reload

# sudo pg_dropcluster 13 main –stop

# sudo pg_upgradecluster 12 main

安装完成

sudo gvm-check-setup

上图表明安装已完成,没有问题。

特征库升级

sudo gvm-feed-update //首次安装后,无需升级,请记住要在以后使用时得升级特征库。

修改密码

首次登录会给一个默认密码,我们登录进去之后直接修改即可

浏览器登录

https://127.0.0.1:9392

You may also like...